Here you can see which phones, tablets, and hearing aid accessories your hearing aids are compatible with.
Simply select your hearing aids and the device you want to know about from the drop-down menus below.

 

Hearing Aids

Choose hearing aids
I don’t know which hearing aids I have

I don’t know which hearing aid I have

 

You can usually find the type of hearing aid in these places:

  • On your hearing aids
  • On your hearing aid case or cover
  • On the receipt from when you bought your hearing aids

If you can’t find your hearing aid type on any of these, ask your hearing care professional or audiologist. You will find your nearest hearing centre here.

Mobile device

Choose phone/tablet
Why is my device not on the list?

Why is my device not on the list?

 

Generally, Oticon strives to be compatible with as many devices as possible. If your device is not on this list, it’s because we haven’t tested it. However, it is still likely to work with our hearing aids and apps if it meets the following criteria:

  • Android OS 8.0 or later
  • iOS 13 or later

Even if that’s not the case, your device might still work, but may not offer full functionality.

  • For Android OS 7.0 or earlier, please see this FAQ 
  • For iOS 12 or earlier, please visit the App Store® as usual

We always recommend using the latest version of the operating system.

If you cannot use our apps, Oticon ConnectClip makes it possible to control your hearing aids without touching them - and to stream sound from your Bluetooth devices.

Clear all
I want to be able to stream directly from my phone to my hearing aid
Direct streaming
Hearing Aids
Accessories
Apps
Phones/Tablets
Show incompatible
are compatible
Hearing Aids
No hearing aids are compatible with your selection.
Accessories
No accessories are compatible with your selection.
Apps
No apps are compatible with your selection.
Phones/Tablets
No devices are compatible with your selection.
COMPATIBLE
INCOMPATIBLE
No direct streaming
Show all
Hide
or later
Requires Android
Requires Streamer Pro
Requires iOS
Requires Bluetooth option